Ultrasn0w Matures To Version 1.2.5, Expands Support

Ultrasn0w Matures To Version 1.2.5, Expands Support

1991
0
SHARE

Carrier locked down IPhone getting you down? Provided you know how to jailbreak I have some good news! Read on to find out moreThe well know unlocking tool Ultrasn0w was updated to version 1.2.5 recently and with it came expanded support for more devices.  The new comers include IPhone 4 baseband 01.59.00, and Iphone 3G and 3GS’s on basebands 04.26.08, 05.11.07, 05.12.01, 05.13.04 and finally 06.15.00. If any of these apply to you then feel free to unlock and jump carriers. Just keep in mind, it does require a jailbreak and that may void your warranty. Try this out at your own risk. Anyone out there brave enough to give this a shot? let s know below.

LEAVE A REPLY

This site uses Akismet to reduce spam. Learn how your comment data is processed.